Getting "this media could not be played" on Twitter videos?

When you scroll through a thread and see an embedded tweet with a gray box where the video should be that says “this media could not be played” you are encountering an error based on the way Twitter stores cookies in your browser. Apparently, the morons at a multi-billion dollar, publicly-traded company can’t hire competent developers to manage cookies correctly.

Here is the fix: on whatever browser you are using, simply go into the settings and clear the cookies. Refresh the page you are looking at and log back into Political Bullpen. All of the videos that you weren’t able to see will be there and ready for viewing.

There is nothing we can do on our end to fix this. It’s an issue with Twitter being stupid. Please don’t complain to us about it. We deal with it too.


Thanks! That fixed it. I just figured it was Twitter censoring videos. Them being stupid is an equally logical explanation.

I get that as well.

I just click on the “500 people are talking about this” and it takes me to the page in a new tab.

Just clear the cookies like Ty said and refresh your page. It’s like magic.

1 Like

Fixed it for me too. Twitter cookies were also taking up an ASSLOAD of space!

1 Like

My browser is actually running really fast now. Everything loads and plays immediately. I thought my year old computer was just a piece of junk. Guess this is something I should do regularly.